<!DOCTYPE html>
<html
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-18626 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_clubindustry/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_clubindustry/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="shortcut icon" href="http://www.clubindustry.com/sites/all/themes/penton_subtheme_clubindustry/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="title" content="Floyd Mayweather To Open Mayweather Boxing &amp; Fitness" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_clubindustry/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_clubindustry/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_clubindustry/images/apple-touch-icons/apple-touch.png" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_clubindustry/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<meta name="description" content="Mayweather intends to open clubs in the United States and abroad, with a focus on &quot;traditionally underserved communities.&quot;" />
<meta name="keywords" content="floyd mayweather, conor mcgregor, mayweather boxing fitness, southern california, james williams, boxing, gym, workout, exercise," />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california" />
<link rel="shortlink" href="http://www.clubindustry.com/node/18626" />
<meta property="og:site_name" content="Club Industry" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California" />
<meta property="og:url" content="http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california" />
<meta property="og:description" content="Boxer Floyd Mayweather intends to open and franchise boxing-oriented fitness clubs in the United States and abroad with a focus on &quot;traditionally underserved communities.&quot;
" />
<meta property="og:updated_time" content="2017-08-17T11:55:20-04:00" />
<meta property="og:image" content="http://www.clubindustry.com/sites/clubindustry.com/files/mayweather-gym-770_1.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california" />
<meta property="twitter:title" content="Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California" />
<meta property="article:published_time" content="2017-08-17T11:47:32-04:00" />
<meta property="article:modified_time" content="2017-08-17T11:55:20-04:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>Floyd Mayweather To Open Mayweather Boxing & Fitness | Club Industry</title>
    <link type="text/css" rel="stylesheet" href="http://www.clubindustry.com/sites/clubindustry.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.clubindustry.com/sites/clubindustry.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.clubindustry.com/sites/clubindustry.com/files/css/css_5s97c60f3VRpsAX_L14fh1vAVHgak1sY-HQSBRlCRrc.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.clubindustry.com/sites/clubindustry.com/files/css/css_zPUcFFUd5PM8DIsCbSi5yNm-Bk-1y4pZHvBd1DH_Xew.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.clubindustry.com/sites/clubindustry.com/files/css/css_ZKsJhsIdlwSx7Yj4YZAhO9aGMW7Vmy5Mi6WrbYd2Xsw.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="http://www.clubindustry.com/sites/clubindustry.com/files/css/css_9wlfiD8oXTbaPtNZgtEQpGROzLEj2b7PKL2hqYQntyI.css" media="all" />
<![endif]-->
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
  </head>
  <body>
    <div id="body-wrapper">
            <!-- Header -->

<header class="header js-header">
  <!-- Pillar Navigation -->
      <nav class="pillar-nav">
      <div class="pillar-nav__inner l-content clearfix">
        <div class="pillar-nav__header">Discover:</div>
        <ul class="pillar-nav__items js-menumore-discover">
                      <li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="http://www.clubindustryshow.com/clb17/Public/Enter.aspx">Club Industry Show</a></li>
                      <li class="pillar-nav__item js-menumore-item-text pillar-nav__item--content "><a href="/store">Store</a></li>
                      <li class="pillar-nav__item js-menumore-item-text pillar-nav__item--content "><a href="https://store.soolis.com/club-industry/">Buyers&#039; Guide</a></li>
                    <li class="pillar-nav__item pillar-more js-menumore-more-item">
            <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
            <ul class="pillar-list-nested js-menumore-sub"></ul>
          </li>
        </ul>
      </div>
    </nav>
    <!-- /Pillar Navigation -->
  <div class="header-inner l-content">
          <!-- Header Hamburger menu -->
      <div class="menu-toggler js-ham-menu-toggler">
        <div class="menu-toggler-img-wrap js-menu-toggler">
          <div class="menu-toggler-hamburger" class="active">
            <div class="hamburger-text">Menu</div>
            <div class="hamburger-line"></div>
            <div class="hamburger-line"></div>
            <div class="hamburger-line"></div>
          </div>
        </div>
        <aside class="hamburger-menu">
          <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
            <div class="hamburger-menu-container">
                              <div class="user-thumb-text">
                  <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>                </div>
                            <ul class="hamburger-menu-nav">
                                                  <li class="hamburger-menu-nav__item">
                    <a href="/news">News</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/trends">Trends</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/resourcebeat">Resourcebeat</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/insights-resources">Insights &amp; Resources</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/insights-resources/webinars">Webinars</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/insights-resources/step-step">Step by Step</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/insights-resources/master-class">Master Class</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/behind-scenes">Blog</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/news-central">News Central</a>                  </li>
                                  <li class="hamburger-menu-nav__item">
                    <a href="/awards-rankings">Awards &amp; Rankings</a>                  </li>
                              </ul>

                              <ul class="hamburger-menu-nav-pillar-menu">
                                      <li class="hamburger-menu-sub-nav__item pillar-nav__item--event">
                      <a href="http://www.clubindustryshow.com/clb17/Public/Enter.aspx">Club Industry Show</a>                    </li>
                                      <li class="hamburger-menu-sub-nav__item pillar-nav__item--content">
                      <a href="/store">Store</a>                    </li>
                                      <li class="hamburger-menu-sub-nav__item pillar-nav__item--content">
                      <a href="https://store.soolis.com/club-industry/">Buyers&#039; Guide</a>                    </li>
                                  </ul>
              
              <ul class="hamburger-menu-sub-nav">
                                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="/subscribe">Newsletters</a>                  </li>
                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="/contact-us">Contact</a>                  </li>
                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="/solutions-succeed-fitness-business-industry">Advertise</a>                  </li>
                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="http://www.penton.com/privacy-policy/">Privacy Policy</a>                  </li>
                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="http://www.penton.com/terms-of-service/">Terms of Service</a>                  </li>
                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech">Ad Choices</a>                  </li>
                                  <li class="hamburger-menu-sub-nav__item">
                    <a href="https://www.instagram.com/clubindustry_fitness/">Instagram</a>                  </li>
                                                  <div class="social-icons">
                                          <a href="https://www.facebook.com/clubindustry.mag"
                         class="social-icons__link social-icons__link_hamburger">
                                                                          <i
                            class="social-icons__icon fa fa-facebook"></i>
                                              </a>
                                          <a href="https://twitter.com/clubindustry"
                         class="social-icons__link social-icons__link_hamburger">
                                                                          <i
                            class="social-icons__icon fa fa-twitter"></i>
                                              </a>
                                          <a href="https://www.linkedin.com/groups/3879923"
                         class="social-icons__link social-icons__link_hamburger">
                                                                          <i
                            class="social-icons__icon fa fa-linkedin"></i>
                                              </a>
                                          <a href="https://www.youtube.com/user/ClubIndustryTV"
                         class="social-icons__link social-icons__link_hamburger">
                                                                          <i
                            class="social-icons__icon fa fa-youtube"></i>
                                              </a>
                                          <a href="https://www.instagram.com/clubindustry_fitness/"
                         class="social-icons__link social-icons__link_hamburger">
                                                                      </a>
                                      </div>
                              </ul>
                          </div>
          </div>
        </aside>
      </div>
      <!-- /Header Hamburger menu -->
        <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="http://www.clubindustry.com/sites/all/themes/penton_subtheme_clubindustry/images/logos/header.png" alt="Club Industry" title="Club Industry" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->

</header>
<!-- /Header -->
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                          <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar slide-normal">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/news/planet-fitness-reports-173-percent-q2-2017-growth-opens-new-hampton-hq">
            Planet Fitness Reports 17.3 Percent Q2 2017 Growth, Opens New Hampton HQ            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Aug 15, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/news/yogaworks-inc-goes-public-nasdaq">
            YogaWorks Inc. Goes Public on NASDAQ            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Aug 11, 2017</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden"">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
              
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/insights-resources/conquer-personal-and-professional-fears-michelle-poler-club-industry-show">
            Conquer Personal and Professional Fears with Michelle Poler at the Club Industry Show            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Aug 10, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/insights-resources/find-practical-retention-help-health-club-operators-all-sizes-all-markets">
            Find Practical Retention Help for Health Club Operators of All Sizes, in All Markets            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Aug 09, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/news/technogym-reports-66-percent-growth-first-half-2017-revenue">
            Technogym Reports 6.6 Percent Growth in First-Half 2017 Revenue            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Aug 08, 2017</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/insights-resources/never-underestimate-power-trade-shows-and-conferences-just-ask-norm-cates">
            Never Underestimate the Power of Trade Shows and Conferences—Just Ask Norm Cates            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 13, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__gallery article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/trends/follow-fitness-leaders-admired-leaders-inside-and-outside-fitness-industry">
            Follow the Fitness Leaders: Admired Leaders Inside and Outside the Fitness Industry            <i class="fa fa-camera"></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 19, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/news/planet-fitness-transgender-friendly-policy-be-challenged-michigan-supreme-court">
            Planet Fitness&#039; Transgender-Friendly Policy to Be Challenged in Michigan Supreme Court            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 13, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/profits/club-industrys-top-100-health-clubs-2016">
            Club Industry&#039;s Top 100 Health Clubs of 2016            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Aug 08, 2016</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

  
  <article itemscope itemtype="http://schema.org/NewsArticle" class="big-article article-type-article article-18626 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="18626" data-url="/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california" data-title="Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California" data-seo-title="Floyd Mayweather To Open Mayweather Boxing &amp; Fitness" data-type="article" data-terms="news" data-pterm="News" data-sterm="Commercial Clubs" data-program="" data-tax="News|Commercial Clubs" data-ext="" data-author="Anthony Dominic" data-pub="Aug 17, 2017" data-visibility="visible" data-perm="public" data-pid="86e46ceb-b12c-4b35-b472-b4cd435a3962" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california"/>
    <meta itemprop="datePublished" content="2017-08-17T19:47:00-04:00"/>    <meta itemprop="dateModified" content="2017-08-17T11:55:20-04:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="http://www.clubindustry.com/sites/all/themes/penton_subtheme_clubindustry/images/logos/header.png">
          <meta itemprop="width" content="936">
          <meta itemprop="height" content="98">
        </div>
        <meta itemprop="name" content="Club Industry">
      </div>
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_featured_retina/public/mayweather-gym-770_1.jpg?itok=M-9j15tG" src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_featured_standard/public/mayweather-gym-770_1.jpg?itok=ewfZcSyJ" width="770" height="400" alt="mayweather-gym-770.jpg" title="mayweather-gym-770.jpg" />          <meta itemprop="url" content="http://www.clubindustry.com/sites/clubindustry.com/files/mayweather-gym-770_1.jpg">
          <meta itemprop="width" content="770">
          <meta itemprop="height" content="440">

                      <span class="text-to-image">Image courtesy Mayweather Boxing & Fitness.</span>
                  </div>
                  <div class="big-article__image-caption add-info">Mayweather Boxing & Fitness will also launch a mobile app and in-home, virtual reality training platform, featuring Floyd Mayweather.</div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><a href="/news">News</a></div>          <h1 itemprop="headline">Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    Boxer Floyd Mayweather intends to open and franchise boxing-oriented fitness clubs in the United States and abroad with a focus on "traditionally underserved communities."
  </div>
            </div>
                    <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/Anthony-Dominic" itemprop="url">Anthony Dominic</a></span> | <span class="date-display-single">Aug 17, 2017</span></p>
        </div>
      </div>

      
    </div>

          <div class="share-icons">
            <a href="/penton_modal/nojs/print/18626"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/18626/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i class="fa fa-envelope"></i>
      </a>
                  <a href="http://www.facebook.com/sharer.php?u=http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california&amp;t=Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California"
         class="facebook"
         target="_blank">
        <i class="fa fa-facebook"></i>
      </a>
                <a href="https://plus.google.com/share?url=http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california"
         class="google-plus"
         target="_blank">
        <i class="fa fa-google-plus"></i>
      </a>
                <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california&amp;title=Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California&amp;summary=After his Aug. 26 superfight against mixed martial artist Conor McGregor, boxer Floyd Mayweather will shift his focus to a new business venture, Mayweather Boxing &amp;amp; Fitness. The flagship boxing club&amp;nbsp;will open this fall in Southern California.&amp;source=Club Industry"
         class="linkedin"
         target="_blank">
        <i class="fa fa-linkedin"></i>
      </a>
                <a href="http://twitter.com/share?url=http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california&amp;text=Floyd Mayweather to Open Mayweather Boxing &amp; Fitness in Southern California"
         class="twitter"
         target="_blank">
        <i class="fa fa-twitter"></i>
      </a>
                <a href="http://pinterest.com/pin/create/button/?url=http://www.clubindustry.com/news/floyd-mayweather-open-mayweather-boxing-fitness-southern-california&amp;description=After his Aug. 26 superfight against mixed martial artist Conor McGregor, boxer Floyd Mayweather will shift his focus to a new business venture, Mayweather Boxing &amp;amp; Fitness. The flagship boxing club&amp;nbsp;will open this fall in Southern California.&amp;media="
         class="pinterest"
         target="_blank">
        <i class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i class="fa fa-pinterest"></i>
        </a>
            </div>

          
    <div class="article-content-wrap">
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
        
        <p>After his Aug. 26 superfight against mixed martial artist Conor McGregor, boxer Floyd Mayweather will shift his focus to a new business venture, Mayweather Boxing &amp; Fitness. The flagship boxing club&nbsp;will open this fall in Southern California.</p>
<p>&ldquo;My whole life has been about boxing and about fitness, and now I&rsquo;m taking everything I developed and bringing it into the fitness market,&rdquo; Mayweather said in a media release provided to Club Industry. &ldquo;Our fitness experience will have programs for kids, parents and aspiring athletes&mdash;anyone who's looking to put energy into something positive. The training programs will be the best in the industry, all based on my own workout routines; and they&rsquo;ll be accessible to all, including communities that don&rsquo;t currently have these kinds of facilities available.&rdquo;</p>
<p>Mayweather intends to open clubs in the United States and abroad, with a focus on "traditionally underserved communities."</p>
<p>According to the release, Mayweather Boxing &amp; Fitness clubs will offer a "unique and scalable business model with an enticing franchisee and affiliate return structure." The clubs will also be supplemented by&nbsp;a mobile app and in-home, virtual reality training&nbsp;platform, featuring Mayweather. The fitness classes will employ elements of Mayweather's personal training&nbsp;regimen.</p>
<p>&ldquo;We&rsquo;ve seen a shift in the fitness industry in that the average consumer is seeking access to the same training that elite athletes have available," James Williams, CEO of Mayweather Boxing &amp; Fitness, said in the release. "And more studios and gyms are now dedicated to a specific discipline. Within those offerings, boxing fitness is a highly popular and extremely effective workout. We are excited to cater to this demand all over the world and be a meaningful part of the next-generation fitness experience, all under the banner and guidance of the most dominant boxer of all time.&rdquo;</p>
<p>Mayweather, 40, will serve as chairman of Mayweather Boxing &amp; Fitness.</p>
        
                                        </div>

      
                <div class="secondary-tags">
      TAGS:              <a href="/news/commercial-clubs" class="secondary-tag">Commercial Clubs</a>        </div>
      
              
  <div class="comments-wrapper" id="comments-18626">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/18626" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body"><div class="field-type-text-long field-name-comment-body field-widget-text-textarea user-comment-field form-wrapper" id="comment_body"><div class="user-photo"><img class="user-thumb-img" src="http://www.clubindustry.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" /></div><div class="user-content"><div class="user-comment"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-18626">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-18626" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="element-invisible publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div></div></div><input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-rgbwGlo68gA1Zo7O08hUi5m7BuByQUiqzBisy5QpY7g" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="" />
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-18626" name="op" value="Save" class="form-submit">Save</button>
</div></div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
      <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/profits/9round-reaches-400-club-milestone-plans-1000-locations-2018" class="small-article-link"><article class="small-article"><div class="img-crop"><img class=" js-imgpxr" data-x2src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_retina/public/uploads/2016/09/shannonhudson9roundfounder-595.jpg?itok=bTOtnPqs" src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_standard/public/uploads/2016/09/shannonhudson9roundfounder-595.jpg?itok=meC3eW9G" width="90" height="83" alt="Shannon Hudson cofounder of 9Round plans to grow his franchised kickboxing business to more than 1000 locations by 2018 Photo courtesy 9Round" /></div><div class="small-article__inner"><div class="small-article__inner-title">9Round Reaches 400 Club Milestone, Plans for 1,000 Locations in 2018 </div><span>Sep 20, 2016</span></div></article></a><a href="/commercial-clubs/nfl-star-rob-gronkowski-launch-fitness-program-boston-sports-clubs" class="small-article-link"><article class="small-article"><div class="img-crop"><img class=" js-imgpxr" data-x2src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_retina/public/uploads/2016/12/gronk-tsi-595.jpg?itok=0ahGFvTz" src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_standard/public/uploads/2016/12/gronk-tsi-595.jpg?itok=eOG7e4iU" width="90" height="83" alt="The Gronk Fitness Program spans four exercise courses that will be held in specially designed Gronk Zone areas of each club Photo courtesy Gronk Fitness Products" /></div><div class="small-article__inner"><div class="small-article__inner-title">NFL Star Rob Gronkowski to Launch Fitness Program at Boston Sports Clubs</div><span>Dec 21, 2016</span></div></article></a><a href="/profits/richard-simmons-closes-slimmons-studio" class="small-article-link"><article class="small-article"><div class="img-crop"><img class=" js-imgpxr" data-x2src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_retina/public/uploads/2016/11/richardsimmons2010cishow-595.jpg?itok=yJ1lRe96" src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_standard/public/uploads/2016/11/richardsimmons2010cishow-595.jpg?itok=mv_Yv7Du" width="90" height="83" alt="Richard Simmons shown here at the 2010 Club Industry Show where he offered the keynote address has closed his studio to take time for himself and to do what he wants to do according to a post on his website Photo by Vincent Johnson" /></div><div class="small-article__inner"><div class="small-article__inner-title">Richard Simmons Closes Slimmons Studio</div><span>Nov 20, 2016</span></div></article></a><a href="/news/planet-fitness-reports-173-percent-q2-2017-growth-opens-new-hampton-hq" class="small-article-link"><article class="small-article"><div class="img-crop"><img class=" js-imgpxr" data-x2src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_retina/public/planet-fit-ext-770-1_0_1.jpg?itok=vz233kEV" src="http://www.clubindustry.com/sites/clubindustry.com/files/styles/article_related_thumb_standard/public/planet-fit-ext-770-1_0_1.jpg?itok=pfo3lGV-" width="90" height="83" alt="planet-fit-ext-770-1_0.jpg" /></div><div class="small-article__inner"><div class="small-article__inner-title">Planet Fitness Reports 17.3 Percent Q2 2017 Growth, Opens New Hampton HQ</div><span>Aug 16, 2017</span></div></article></a></div>    </div>

    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/news/planet-fitness-reports-173-percent-q2-2017-growth-opens-new-hampton-hq?parent=18626&infscr=1" rel="nofollow">Load More</a></li>
<li class="last"><a href="/news/planet-fitness-reports-173-percent-q2-2017-growth-opens-new-hampton-hq" rel="next">Next Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <!-- Check to see if we are in the store -->
  <footer class="l-footer l-footer-min">
    <div class="l-footer-inner">
      <div class="l-footer-info">
        <div class="footer-logo-min">
                      <a href="/"><img class="footer-logo-min__site_logo" src="http://www.clubindustry.com/sites/all/themes/penton_subtheme_clubindustry/images/logos/footer.png" alt="Logo" /></a>                    <a href="http://www.penton.com/"><img class="footer-logo-min__penton_logo" src="http://www.clubindustry.com/sites/all/themes/penton_core_theme/images/powered_by_penton_360.png" alt="Logo" /></a>        </div>
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact</a>    </li>
          <li class="footer-min-col__item">
      <a href="/solutions-succeed-fitness-business-industry" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/subscribe" class="footer-min-col-link">Newsletters</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
  </ul>
  <div class="social-min-col">
    <p class="social-min-col__label">Follow us:</p>
    <div class="social-icons social-icons_footer">
              <a href="https://www.facebook.com/clubindustry.mag" class="social-icons__link social-icons__link_footer">
                      <i class="social-icons__icon fa fa-facebook"></i>
                  </a>
              <a href="https://twitter.com/clubindustry" class="social-icons__link social-icons__link_footer">
                      <i class="social-icons__icon fa fa-twitter"></i>
                  </a>
              <a href="https://www.linkedin.com/groups/3879923" class="social-icons__link social-icons__link_footer">
                      <i class="social-icons__icon fa fa-linkedin"></i>
                  </a>
              <a href="https://www.youtube.com/user/ClubIndustryTV" class="social-icons__link social-icons__link_footer">
                      <i class="social-icons__icon fa fa-youtube"></i>
                  </a>
          </div>
  </div>
      </div>
      <div class="l-footer-rights">
        <span class="copyrights">
          Copyright&nbsp;&#169; 2017 Penton
        </span>
      </div>
    </div>
  </footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_SVq9iKRs_zDCxLo1JNNm7Cgvo_36UjooUTG_HwKIgLU.js"></script>
<script type="text/javascript" src="http://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_rEbPjuAQEoiYmG4a5yzi-U2v_aueuyLZiOvf47eP2U8.js"></script>
<script type="text/javascript" src="//assets.adobedtm.com/2ebe67d2ca0193084439038012c34f9112a85c00/satelliteLib-969013af7daa18053e3c96f6bea867c670792fb1.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_wPsPXZ--zkZLVfZ7Y1b6-OnPbFKug04pMqOU7CGywMQ.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_vIDonzt0CKSucCzqTIsh7iVTnRZ3tRtKbiYuvWh5gRU.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_FloLC-L2hL--gn7qKaXXBNWxL6qI_-SL4q2_WBFL5X4.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="//assettvus.getmediamanager.com/js/mm.embed.v1.min.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_eCcj0PDlb78q7dLzlSpqxYOtYaQH02MEnIUNUUvrox8.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_m0Qm7ZLBa0Us5bK_pvZ1T3hMtRZOtWiklopETCWH6Qk.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_5mQRjT6JaGwJbFtgNHMqzn5sYO39PeYLojv87L-x2LE.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_s-cnAcPgF-HgRkOajJdwvphG1w8jfGAbmGEX4-HSjlw.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_-xuAz7m58L27Z49ZRZ183IQRNupgBXqOgWLzaxamigo.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_EJf0JlhteEmwVTVALzJb04AR0Z2yHA-jTy_zmcUhGc4.js"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?ouw7nt"></script>
<script type="text/javascript" src="http://www.clubindustry.com/sites/clubindustry.com/files/js/js_u7WRB7owEsqhtZCp3_QHgUPL4U38ov7V2G_P-tNQ1R8.js"></script>
    </div>
  </body>
</html>
